博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
bzoj1620:时间管理
阅读量:4472 次
发布时间:2019-06-08

本文共 2463 字,大约阅读时间需要 8 分钟。

1620: [Usaco2008 Nov]Time Management 时间管理

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 571  Solved: 343
[][][]

Description

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

N个工作,每个工作其所需时间,及完成的Deadline,问要完成所有工作,最迟要什么时候开始.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

Output

* Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

Sample Input

4
3 5
8 14
5 20
1 16
INPUT DETAILS:
Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of
time, respectively, and must be completed by time 5, 14, 20, and
16, respectively.

Sample Output

2
OUTPUT DETAILS:
Farmer John must start the first job at time 2. Then he can do
the second, fourth, and third jobs in that order to finish on time.

HINT

 

Source

先排序一下,注意是排序完成的时间,然后用二分答案就ok了,感觉就是好像如果能用枚举的话用二分答案搞。

我草草草草一直wa居然是因为一个点需要输出-1!!!看题看题看题看题!!!

--------------------------------------------------------------------------------------------------

#include<cstdio>

#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int n;
struct edge{
 int dis,to;
 bool operator<(const edge&rhs) const{
   return to<rhs.to;}
};
edge edges[1005];
bool pd(int x){
    int ans=x;
 for(int i=1;i<=n;i++){
  edge &s=edges[i];
  ans+=s.dis;
     if(ans>s.to)
       return false;
 }
 return true;
}
int main(){
 scanf("%d",&n);
 int ans=-2;
 int l=0;int r=0x7fffffff;
 for(int i=1;i<=n;i++){
  scanf("%d%d",&edges[i].dis,&edges[i].to);
  r=min(r,edges[i].to);
 }
 sort(edges+1,edges+n+1);
 while(l<=r){
  int m=(l+r)/2;
     if(pd(m)){
      ans=m,l=m+1;
     }
     else
       r=m-1;
 }
 if(ans!=-2)
   printf("%d\n",ans);
 else
   printf("-1");
 return 0;
}

-------------------------------------------------------------------------------

转载于:https://www.cnblogs.com/20003238wzc--/p/4805498.html

你可能感兴趣的文章
Azure Cosmos DB 使用费用参考
查看>>
【嵌入式开发】写入开发板Linux系统-模型S3C6410
查看>>
C# 子线程与主线程通讯方法一
查看>>
006——修改tomacat的编码
查看>>
《C程序设计语言》笔记 (八) UNIX系统接口
查看>>
git常用命令
查看>>
Android必知必会-获取视频文件的截图、缩略图
查看>>
(转)理解Bitblt、StretchBlt与SetDIBitsToDevice、StretchDibits
查看>>
ViurtualBox配置虚拟机Linux的网络环境
查看>>
VLC 媒体播放器
查看>>
勿忘国耻2018/09/18
查看>>
Jenkins部署码云SpringBoot项目
查看>>
多标签分类(multi-label classification)综述
查看>>
史上最全面的Spring-Boot-Cache使用与整合
查看>>
图的遍历(深度优先与广度优先搜索两种方案)
查看>>
快速读入模板
查看>>
\n ^ \t的使用
查看>>
css盒模型
查看>>
探索式测试:测试自动化
查看>>
make install fping
查看>>